Jealous Jellyfish
http://jealousjellyfish.de/

AN2 Mod-Problem: Schiffstexturen-Fehler
http://jealousjellyfish.de/viewtopic.php?f=11&t=412
Seite 1 von 1

Autor:  Rochendämon [ Montag 18. September 2017, 17:43 ]
Betreff des Beitrags:  AN2 Mod-Problem: Schiffstexturen-Fehler

Licht!

Bin vor einer Weile auf ein Paket mit Tools (auf ModDB) gestoßen und bastle jetzt ein bisschen an AN2, zum persönlichen Amusement. Ausrüstung bearbeiten geht bis zu einem bestimmten Punkt, auch wenn das Spiel anscheinend keine neuen Waffen, Projektile oder Spielerschiffe (liegt wohl am Auswahlmenü) einlesen kann. Also, dachte ich mir, tausche ich das Modell/Mesh eines Spieler-Bootes einfach aus. Habe dazu zuerst mal versucht, das Modell für die "Angelina-Argon" aus den Sofort-Trainingsmissionen gegen eine EnTrOx-Expurgator auszutauschen - einfach nur die Referenz in der osd-Datei kopiert. Das Modell/Mesh wird zwar angezeigt, aber die Textur fehlt oder ist irgendwie verbuggt - das Schiff sieht silbrig aus und reflektiert Lichter, wie "verchromt". Zwei weitere Versuche - Maggie zu ENT-Executor und Lacewing zu Succubus I (ich dachte, dass es vielleicht daran liegt, dass man ein Modell aus der "pla"-Kategorie braucht) - hatten dasselbe Ergebnis. Die Modelle von NPC-Schiffen lassen sich dagegen scheinbar problemlos auswechseln; habe Animal testweise eine Bloodshot II/Bandog gegeben. Hat jemand hier schon mal etwas ähnliches versucht und weiß, warum das bei Spielerschiffen nicht richtig dargestellt wird?

(I could also try to explain my issue in english, if that helps.)

Autor:  doomgun [ Dienstag 19. September 2017, 01:39 ]
Betreff des Beitrags:  Re: AN2 Mod-Problem: Schiffstexturen-Fehler

quote:


Rochendämon hat geschrieben:
Licht!

Bin vor einer Weile auf ein Paket mit Tools (auf ModDB) gestoßen und bastle jetzt ein bisschen an AN2, zum persönlichen Amusement. Ausrüstung bearbeiten geht bis zu einem bestimmten Punkt, auch wenn das Spiel anscheinend keine neuen Waffen, Projektile oder Spielerschiffe (liegt wohl am Auswahlmenü) einlesen kann. Also, dachte ich mir, tausche ich das Modell/Mesh eines Spieler-Bootes einfach aus. Habe dazu zuerst mal versucht, das Modell für die "Angelina-Argon" aus den Sofort-Trainingsmissionen gegen eine EnTrOx-Expurgator auszutauschen - einfach nur die Referenz in der osd-Datei kopiert. Das Modell/Mesh wird zwar angezeigt, aber die Textur fehlt oder ist irgendwie verbuggt - das Schiff sieht silbrig aus und reflektiert Lichter, wie "verchromt". Zwei weitere Versuche - Maggie zu ENT-Executor und Lacewing zu Succubus I (ich dachte, dass es vielleicht daran liegt, dass man ein Modell aus der "pla"-Kategorie braucht) - hatten dasselbe Ergebnis. Die Modelle von NPC-Schiffen lassen sich dagegen scheinbar problemlos auswechseln; habe Animal testweise eine Bloodshot II/Bandog gegeben. Hat jemand hier schon mal etwas ähnliches versucht und weiß, warum das bei Spielerschiffen nicht richtig dargestellt wird?

(I could also try to explain my issue in english, if that helps.)


Licht!

I am not perfect at German language, I translated it via google-translator, but I understand your problem. This modding tools which I uploaded to Moddb are not so useful to change or create new models. I tried this manupulations with replacing and I had same problem like yours. For now there is no solution how to change models without any trouble. So, I am waiting for when AN Deep Descent will be released, and then I wanna ask developers for tools to edit AquaNox games.

But you can change several game scripts and maybe textures.

Autor:  Rochendämon [ Dienstag 19. September 2017, 18:06 ]
Betreff des Beitrags:  Re: AN2 Mod-Problem: Schiffstexturen-Fehler

I only used the that one tool to extract the .pak files of the game in order to access the configuration files.
The strange point is that I essentially just changed the game's internal reference in the osd file for the ship.

For example, I changed

[Visual]
{
M0 = pla_instant_atlscout.msh
L0 = 512.0
}

to

[Visual]
{
M0 = ent_scout.msh
L0 = 512.0
}

which should make the game load another already existing mesh from its files for that ship. I did not change the meshes themselves.
This works fine for NPC ships (just did this on Animal's boat yesterday and it perfectly looks like an ENT-Scout now), but not for the player ship files.
The ship's model is displayed correctly, just the texture is either missing or bugged.

Edit: Which scripts do you mean? I tried to play around with the mission script files. I edited an .scc file of an instant mission with Notepad to exchange a weapon for the player, but the game crashed with something like an "Access Violation". I then guessed that I either need a special editor or decompiler to edit that file. I have no experience with Lua though (I guess the game's scripts use lua).

Autor:  doomgun [ Montag 25. September 2017, 05:38 ]
Betreff des Beitrags:  Re: AN2 Mod-Problem: Schiffstexturen-Fehler

I tried to do some experiments with mission scripts. So I added one weapon (sizzler) and one friendly ship which can help you in battle, for instant mission - 1. It is working, and yes, it is using LUA. If you want to change something or add in mission, you should use "AN2 scripts" package (if I didn't forget to put it in).

If you wanna try it, here it is https://drive.google.com/open?id=0B1HAddPKBiiyRUQtMFZCTVVVd0U

Autor:  doomgun [ Mittwoch 4. Oktober 2017, 08:15 ]
Betreff des Beitrags:  Re: AN2 Mod-Problem: Schiffstexturen-Fehler

I figured out new things about how to make custom models working in game for AN2.

Check this:

http://jealousjellyfish.de/viewtopic.php?f=10&t=415

Seite 1 von 1 Alle Zeiten sind UTC + 1 Stunde
Powered by phpBB® Forum Software © phpBB Group
https://www.phpbb.com/